Tag: backtobackvpc

Back to Back VPC

Back to Back VPC

Merhaba Arkadaşlar ;

Makalemizin konusu “Back to Back VPC”  adından da anlaşılacağı üzere farklı vpc domainlerininin art arda bağlanmasıdır.

Önce vpc den biraz bahsedelim sonrasında da konfigürasyon örneğimize bakalım

Vpc nedir ?

Açılımı Virtual Port Channel olan ; cihazın tüm portlarını stp gibi blocklamadan  tam kapasitede çalışmasını sağlayan ve bize L2 yedeklilik sağlayan bir teknolojidir.

Aşağıdaki yapıdan da anlaşılacağı üzere access cihazlar VPC domain üyesi olan cihazlara bağlanır , link koptuğu vakit diğer linkten iletişimine devam eder.Buradaki süre STP çalışan bir sisteme oranla çok düşük olduğu için sistem kesintiye uğramaz  

 

 

Biz makalemizde 2 adet vpc domainini art arda bağlayacağız.Kafanızda daha iyi oturması adına aşağıdaki topolojiden devam edelim

Elimizde bir çift N9K ve birçift de N3K larımız var

NX9K ları kendi aralarında , NX3K ları kendi aralarında vpc domain1 ve vpc domain2 olarak yapılandırıyoruz. Daha sonrasında her iki tarafta da AYNI ID de  bir portchannel oluşturup ilgili portları member ediyoruz.Dikkat edilmesi gereken nokta LACP, VRRP gibi teknolojileri kullanırken AYRI portchannel id leri kullanırken  VPC de AYNI portchanel id sini kullanmalıyız.

 

Vpc 998 BackToBack bağlantımızı sağlayacak portlardır.

İlgili konfigürasyonumuz aşağıdadır.
NX9K-01#

vpc domain 1
peer-switch
role priority 1000
peer-keepalive destination 4.4.4.2 source 4.4.4.1 vrf VPC
delay restore 150
peer-gateway
auto-recovery
ip arp synchronize

interface Ethernet1/46
vrf member VPC
ip address 4.4.4.1/30
no shutdown

interface port-channel999
description PEERLINK
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface Ethernet1/53

description PEERLINK
switchport
switchport mode trunk
channel-group 999 mode active
no shutdown

interface Ethernet1/54

description PEERLINK
switchport
switchport mode trunk
channel-group 999 mode active
no shutdown

interface port-channel998
description BACKTOBACKVPC
switchport
switchport mode trunk
vpc 998

interface Ethernet1/47

description BACKTOBACKVPC
switchport
switchport mode trunk
channel-group 998 mode active
no shutdown

interface Ethernet1/48

description BACKTOBACKVPC
switchport
switchport mode trunk
channel-group 998 mode active
no shutdown

NX3K-01# 

vpc domain 2
role priority 1000
peer-keepalive destination 2.2.2.2 source 2.2.2.1 vrf VPC
delay restore 150
peer-gateway
auto-recovery
ip arp synchronize

interface Ethernet1/46
description KEEPALIVE
no switchport
speed 1000
vrf member VPC
ip address 2.2.2.1/30

interface port-channel2
description PEERLINK
switchport mode trunk
spanning-tree port type network
speed 40000
vpc peer-link

interface Ethernet1/53

description PEERLINK
switchport mode trunk
channel-group 2 mode active
no shutdown

interface Ethernet1/54

description PEERLINK
switchport mode trunk
channel-group 2 mode active
no shutdown

interface port-channel998
description BACKTOBACKVPC
switchport mode trunk
speed 10000
vpc 998

interface Ethernet1/47

description BACKTOBACKVPC
switchport mode trunk
channel-group 998 mode active

interface Ethernet1/48

description BACKTOBACKVPC
switchport mode trunk
channel-group 998 mode active

 

 

Enjoy this blog? Please spread the word :)