Cisco 4G Router Konfigürasyonu

Cisco 4G Router Konfigürasyonu

Merhaba Arkadaşlar

Bu yazımda sizlere Cisco 3G (LTE desktekli) router üzerinde adsl ve gsm hatlarımızı sonlandırılmış bir konfigürasyon dosyası paylaşağım

Demoda kullandığımız router 880G güncel ios lu bir router bu yüzden çok fazla sorun yaşadım daha kalıcı olması için anlatmatma istediği duydum.

Yapacağımız demo yu biraz açıklayalım 2 adet wan bacağımız olacak 1. ADSL , 2. 3G(TURKCELL data hattı) biri gittiği vakit diğerinin devreye girmesini sağlayacağız bildiğiniz isp redundancy 

cisco3g

Konfigürasyonu paylaşmadan önce açıklamak istediğim bir kaç ufak nokta var

Cihaz sim kartı takıldıktan sonra ip alabilmesi için pin numarasını girilmesi gerekmektedir.(telefonu açarken kullandığınız güvenlik numarası)

Diğer dikkat edilmesi gereken konu aldığınız hat static ise mgbs dinamikse mgb tanımı yapılmalı demodaki hattımız static olduğu için mgbs tanımı yapıyorum.

Dikkat ederseniz sim kart ile işlemlerin hepsi privilege mode da yapılmaktadır.

DEMO01-3G-01# cellular 0 lte sim unlock şifre

DEMO01-3G-01#cellular 0 lte profile create 1 mgbs chap null null

Buraya kadar herşey doğruysa kontrol için kullanacağımız komut

DEMO01-3G-01#sh cellular 0 profile 1

Profile 1 = ACTIVE* **

PDP Type = IPv4

PDP address = 5.xx.1x.1×2 (aldığımız statik ip)

Access Point Name (APN) = mgbs

Authentication = PAP

Username: null

Password: null

Primary DNS address = 86.108.132.254

Secondary DNS address = 188.59.242.200

 

* – Default profile

Forumlarda da göreceğiniz üzere chat scrip bu ios da biraz daha farklı çalışan yapıdaki chat scrip aşağıdaki gibidir.

chat-script lte “” “AT!CALL1” TIMEOUT 20 “OK”

 

Building configuration…

Current configuration : 5747 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DEMO01-3G-01
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1197409441
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1197409441
revocation-check none
rsakeypair TP-self-signed-1197409441
!
!
crypto pki certificate chain TP-self-signed-1197409441
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31313937 34303934 3431301E 170D3135 31323034 31393132
31395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31393734

!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LOCALNETWORK
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
lease 0 2
!
ip domain name demo.local
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
chat-script lte “” “AT!CALL1” TIMEOUT 20 “OK”
!
cts logging verbose
license udi pid C887VAG-4G-GA-K9 sn FCZ193092Y0
!
!

object-group network LOCAL_LAN_SUBNET
192.168.1.0 255.255.255.0
!
username admin privilege 15 secret 5 $1$Wkfb$!
!
controller VDSL 0
operating mode adsl2
!
controller Cellular 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
no cdp run
!
track 1 ip sla 1 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
description ADSL
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Cellular0
description BACKUP_WAN_3G
no ip address
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer pool-member 2
dialer-group 2
no peer default ip address
async mode interactive
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
description LOCAL_VLAN1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
description PRIMARY_ADSL
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp pap sent-username [email protected] password 0 123123
ppp ipcp dns request
no cdp enable
!
interface Dialer2
description BACKUP_TURKCEL3G
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 2
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 2
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source route-map nat2backup interface Dialer2 overload
ip nat inside source route-map nat2primary interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
ip route 0.0.0.0 0.0.0.0 Dialer2 253
!
ip access-list extended nat-list
permit ip object-group LOCAL_LAN_SUBNET any
deny ip any any
!
ip sla auto discovery
ip sla 1
icmp-echo 8.8.8.8 source-interface Dialer1
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
route-map track-primary-if permit 1
match ip address 197
set interface Dialer1
!
route-map nat2primary permit 1
match ip address nat-list
match interface Dialer1
!
route-map nat2backup permit 1
match ip address nat-list
match interface Dialer2
!
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 197 permit icmp any host 8.8.8.8
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
login local
no modem enable
line aux 0

line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport input all
transport output all
speed 384000
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
!
!
end

 

 

 

 

2 Replies to “Cisco 4G Router Konfigürasyonu”

  1. Merhaba hocam iyigünler elimde cisco 887vag k9 modeli var bunu adsl modem olarak kurulum yaptım hattımı ttnet veya turknete vdsl geçirip kullanmak istiyorum hangi configi girmem gerekir? şuan adsl olarak yapılı ttnet- turknet vdsl için doğrumudur bu configler? kolaygelsin saygılar.

    Video showing how to configure a Cisco 887 router for VDSL (based on a BT Infinity service – UK)

    1. VDSL Interface and subinterface

    interface Ethernet0
    no ip address

    interface Ethernet0.101
    encapsulation dot1Q 101
    pppoe enable
    pppoe-client dial-pool-number 1

    2.Shut down the ATM interface and subinterfaces

    interface ATM0
    shutdown

    3.Create the Dialer1 interface

    interface Dialer1
    description Dialer interface for VDSL
    mtu 1492
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    ppp authentication pap chap ms-chap callin
    ppp chap hostname xxxx
    ppp chap password xxxx
    ppp ipcp address accept
    no cdp enable

  2. Merhaba Mert
    Vdsl için aşağıdaki konfiği kullanabilirsin

    controller VDSL 0/2/0
    interface Ethernet0/2/0.35
    encapsulation dot1Q 35
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface Dialer1
    description PRIMARY_WAN
    ip address negotiated
    ip mtu 1452
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 123456
    ppp pap sent-username [email protected] password 0 123456
    ppp ipcp dns request

Leave a Reply

Your email address will not be published.

Enjoy this blog? Please spread the word :)